ReproConnect - Sporadic email delivery failures – Incident details

All systems operational

Sporadic email delivery failures

Resolved
Degraded performance
Started 8 days agoLasted about 3 hours

Affected

Email delivery

Degraded performance from 9:35 PM to 12:42 AM

Updates
  • Resolved
    Resolved
    We have been reviewing our logs of all email attempts today and will resend any email notifications where we don't have a confirmed delivery. You may see notifications hit your inboxes late tonight. Some of these might be duplicates; however, we'd rather ensure that you have notification for any print orders, even if late or duplicated.
  • Identified
    Identified

    Several customers have reported not receiving email notifications for uploads/transfers today. The issue appears to be quite sporadic; the vast majority of emails are being delivered as usual. Nevertheless, we encourage you to keep a close eye on your Control Center for the moment to ensure you don't miss an order.

    We are working with our email provider to troubleshoot the issue.