All systems operational

Email delays with file transfer notifications

Resolved
Degraded performance
Started over 1 year ago Lasted about 13 hours

Affected

Email delivery
Updates
  • Resolved
    Resolved
  • Monitoring
    Monitoring

    We are seeing significant numbers of emails now getting delivered. The delay is not fully resolved just yet, but real progress is being made with the email provider.

    We understand it's been frustrating for those of you that rely on email notifications for your print orders, and we're working hard to see this fully resolved.

  • Identified
    Identified

    Apologies, we spoke too soon. Our email provider indicated it was resolved, but we're back to delays again.

    In addition to resolving this issue, we are working to get alerts built right into your Control Center when there are system issues like this, to keep your team better informed.

  • Monitoring
    Monitoring

    The email delay has been mostly resolved. Notification emails are flowing right now, you should receive all delayed emails from the past hour or so. We'll monitor things until we're sure there are no further issues.

  • Identified
    Identified

    The email delivery provider that handles all the notifications for file transfers is currently experiencing delays. They are working on the issue, and we will update here when it is resolved.

    In the meantime, make sure to keep an eye on the "Transfers" screen in your Control Center. You can turn on desktop notifications to get instant alerts when a transfer is received.