All systems operational

Email delays with upload notifications

Resolved
Degraded performance
Started over 3 years ago Lasted about 1 hour

Affected

Email delivery
Updates
  • Resolved
    Resolved

    New email notifications are flowing normally again, and our email provider is working through the backlog of queued emails. It should all be caught up shortly.

  • Investigating
    Investigating

    We are seeing some delays with FileRocket upload notification emails. Emails are being queued while our email service provider works on the issue. In the meantime, we strongly recommend keeping a close eye on your FileRocket console (https://app.filerocket.com) or your ReproConnect Control Center to stay aware of new transfers.