All systems operational

Intermittent issues with AWS

Resolved
Degraded performance
Started over 2 years ago Lasted about 10 hours

Affected

Planroom websites
Document viewing
Electronic bidding
Updates
  • Resolved
    Resolved
  • Monitoring
    Monitoring

    Within the past few hours we've seen most AWS services recover. We are now at the point where all planroom functionality appears to be working as expected. We will continue to monitor and verify operations.

  • Identified
    Identified

    AWS has acknowledged they are experiencing increased errors on their end that are impacting multiple services. The issues still appear to be sporadic.

    You may see some recently uploaded files that aren't converting properly for the viewer, or you may hit an error when uploading files to projects on the planroom. We are also seeing some errors when users try to download files.

    We continue to monitor the situation closely. AWS reports they are working on a resolution.

  • Investigating
    Investigating

    We are seeing sporadic issues with AWS across multiple services. Your customers might be intermittently getting error messages with logins, uploading or downloading files, and other actions.

    We will update this incident when we have more information.